Mouse speed in Linux 
Sunday, June 10, 2007, 07:44 PM - Programs
do: xset m 1/4 10 // 1/4 = speed 1/2 or 3 up to like 7
in this fodler: /usr/X11R6/bin


Worked for me, we'll see if it stick after reboot.

[ add comment ]   |  permalink  |  related link  |   ( 3.1 / 395 )
Canon EOS Rebel XTi (400D) with Digikam 
Thursday, June 7, 2007, 12:38 PM - Programs
Problem: Canon EOS 400D / Rebel XTI is not supported after install.

Resolution:

Open a terminal and redirect output to a text file:

for dev in `ls /sys/bus/usb/devices`; do udevinfo -ap /sys/bus/usb/devices/$dev; done > /home/yourusername/udevinfo.txt

Open the udevinfo.txt and search for canon

It will look like this:

looking at device '/devices/pci0000:00/0000:00:1d.7/usb5/5-5':
ID=="5-5"
BUS=="usb"
DRIVER=="usb"
SYSFS{configuration}==""
SYSFS{product}=="Canon Digital Camera"
SYSFS{manufacturer}=="Canon Inc."
SYSFS{maxchild}=="0"
SYSFS{version}==" 2.00"
SYSFS{devnum}=="7"
SYSFS{speed}=="480"
SYSFS{bMaxPacketSize0}=="64"
SYSFS{bNumConfigurations}=="1"
SYSFS{bDeviceProtocol}=="00"
SYSFS{bDeviceSubClass}=="00"
SYSFS{bDeviceClass}=="00"
SYSFS{bcdDevice}=="0002"
SYSFS{idProduct}=="3110" <--------
SYSFS{idVendor}=="04a9" <--------
SYSFS{bMaxPower}==" 2mA"
SYSFS{bmAttributes}=="c0"
SYSFS{bConfigurationValue}=="1"
SYSFS{bNumInterfaces}==" 1"

Open /etc/udev/rules.d/45-libgphoto2.rules

sudo nano -w /etc/udev/rules.d/45-libgphoto2.rules

Add the following lines at the bottom of the file, just before LABEL="libgphoto2_rules_end"

SYSFS{idVendor}=="YOURIDVENDOR", SYSFS{idProduct}=="YOURIDPRODUCT", MODE="0660", GROUP="plugdev"

For me it was:

SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="3110", MODE="0660", GROUP="plugdev"

Restart udev

Code:

sudo /etc/init.d/udev restart



via: http://ubuntuforums.org/showthread.php? ... hlight=xti

i got sick of searching for it over and over again.

[ add comment ]   |  permalink  |  related link  |   ( 3 / 872 )
Wheel Mouse iin SLAX 
Sunday, August 13, 2006, 10:34 PM - Programs
u need to add/change folowing lines in your xorg.conf file:

Section
"InputDevice"
# Identifier and driver
Identifier "Mouse1" Driver "mouse"
...


change

Option "Protocol" "PS/2"

to
Option "Protocol" "IMPS/2"


and add the line

Option "ZAxisMapping" "4 5"


after that restart or start X

[ add comment ]   |  permalink  |  related link  |   ( 3 / 676 )
Vim in Slackware 
Thursday, May 4, 2006, 02:18 PM - Programs
ya, vim in slackware sucks balls....

here is how to fix it.

~$ cp /usr/share/vim/vim63/vimrc_example.vim ~/.vimrc
~$ cp /usr/share/vim/vim63/gvimrc_example.vim ~/.gvimrc

[ add comment ]   |  permalink  |  related link  |   ( 2.9 / 435 )